JLab und EDL

Alles zum Thema Instrumentation (Anzeige- und Steuersoftware) auf Computerseite (Labview, JLab, ...) kann hier rein: Installation, Komponenten, Probleme...
Antworten
Rainer
kann c't-Lab-Module umbauen
kann c't-Lab-Module umbauen
Beiträge: 75
Registriert: 29.11.2007, 01:38
Kontaktdaten:

JLab und EDL

Beitrag von Rainer » 08.10.2012, 12:57

Hi,

ich benutze gerade das erste mal JLab 3.0.2 mit dem EDL Modul um einen Akku kontrolliert zu entladen und Spannung/Strom/Ladung per Graph zu erfassen. Das funktioniert soweit auch ganz gut, aber mir sind ein paar Kleinigkeiten dabei aufgefallen, die mir nicht so ganz klar sind.

Ich kann in dem JLab Panel für das EDL die Abschaltspannung immer nur als Ganzzahl eingeben, wodurch ich natürlich nicht genau die Abschaltgrenze erreiche, die ich gerne hätte. Es wäre schön, wenn man dort auch Kommazahlen eintragen könnte.

Dann habe ich oben zwei Stromwerte, die ich einstellen kann. Der erste mit mA und der zweite mit A beschriftet. Der benutze Entladestrom scheint im zweiten Kästchen zu sein, aber wofür ist das erste dann?

Und ich habe mein EDL für maximal 10A/50W aufgebaut nach der Anleitung in der ct. Aber der maximal erlaubte Strom mit dem Slider beträgt nur 1A. Kann ich die Grenze irgendwo konfigurieren?

In dem Graphen für "accumulated current" wird W und nicht Ah angezeigt, was vermutlich nur ein Tippfehler ist.

Ich habe auch keine Möglichkeit gefunden in den Graphen die Obergrenze für die Y-Achse einzustellen. Z.B. bei dem akkumulierten Strom habe ich unter Umständen nur sehr kleine Werte, weshalb ich bei den vorgegebenen Grenzen fast keine Änderung im Graphen sehen kann. Kann man die Ober-/Untergrenzen der einzelnen Graphen irgendwo vorgeben um einen besseren Verlauf sehen zu können?

Zu guter letzt wundere ich mich etwas über die CPU Auslastung. Bei einem EDL Panel und drei Graphen braucht die GUI mittlerweile 100% CPU von einem Kern, sobald diese angezeigt wird. Klicke ich sie in den Hintergrund geht die CPU Last auf ~1% herunter. Das war aber kurz nach dem Start von JLab noch nicht. Mittlerweile ist die gesamte GUI sehr langsam und reagiert nur stark verzögert auf den Mauscursor.

Ich verwende Java 1.6.0_35 32Bit Runtime unter Win7 64Bit, falls das helfen sollte.
Ich hoffe, Jemand kann mir dabei etwas weiterhelfen. :)

Nachtrag:
Ich habe eben herausgefunden, dass nur die Graphen für die extreme CPU Last verantwortlich sind. Sobald man den Zeitrahmen in den Stundenbereich legt (1h, 3h, 10h) und es eine Zeit lang laufen lässt wird die GUI zunehmend langsamer. Irgend wann ist sie dann kaum noch zu bedienen. Wenn ich die Graphen schließe ist wieder alles normal.

Zweiter Nachtrag:
Die Abschaltspannung scheint entweder nicht zu funktionieren oder hat einen anderen Sinn als ich erwartet hatte. Ich habe 11V eingetragen gehabt und als ich später nachgeschaut hatte, war der Akku schon auf 9,6V herunter und wurde weiter entladen. :(
Nun weiss ich nicht, ob das ein Problem mit JLab oder dem EDL ansich ist. Aber ich kann das morgen mal testen, indem ich das DCG als Akku-Ersatz dranhänge und die Spannung runter drehe.

Ciao,
Rainer

Antworten