PS3-2 LM2940 im Leerlauf nicht stabil

Hier könnt ihr Diskussionen über das Interface, die Stromversorgung und das Bedienpanel des c't-Lab führen.
Antworten
Neuling
kann c't-Lab-Bausätze löten
kann c't-Lab-Bausätze löten
Beiträge: 29
Registriert: 15.06.2013, 12:45

PS3-2 LM2940 im Leerlauf nicht stabil

Beitrag von Neuling » 20.04.2015, 17:16

Das Modul PS3-2 (mit 3x Flachtrafo) aufgebaut zeigt bei mir ohne Last eine Sägezahnschwingung von ca. 5kHz am Ausgang des LM2940. Auch der 7915 ist im Leerlauf und leichter Last (2-3 kOhm) nicht ganz stabil.
Ein Blick in die entsprechenden Datenblätter zeigt, dass der LM2940 für garantierte Stabilität am Ausgang einen Kondensator von 22µF mit niedrigem ESR benötigt und der 7915 einen mit mindesten 1µF.

Es kann sein, dass die Elkos in den Modulen hinreichend Kapazität für einen sauberen Betrieb haben, aber wenn man auf Nummer sicher gehen will, sollte man C1 und C13 durch einen Tantal-C mit > 1µ (ich habe 4,7µ/35V genommen) und C8 und C12 durch einen mit 22µ (bei mir 33µ/16V) ersetzen.

Beim Einsatz des PS3-2 in Verbindung mit DIV ist zu beachten, dass der 6V-(Flach)Trafo eine niedrigere Spannung an DVgl+ liefert als der 9V-Trafo im IFP, sodass die 12V-Relais - sowohl die G5V2 12V (Segor) als auch Finder 30.22.09 12V (Reichelt) - bei Berücksichtigung von 10% Netzunterspannung, der Sättigungsspannung des ULN2803 und 3 geschalteten Einheiten deutlich außerhalb des garantierten Arbeitsbereichs lt. entsprechendem Datenblatt liegen (ca. 75% Unenn resp 8,4V; Netzteil nachgerechnet gemäß Tietze/Schenk, Aufl. 1998, Kap. 18.2.2). Es gibt für den Betrieb des DIV zweieinhalb Möglichkeiten: es am IFP betreiben oder die 6V Ausführung der Finder-Relais einsetzen (die halbe: es einfach versuchen und sich aufs Glück verlassen :-)). Die 5V Ausführung des G5V2 geht nicht: bei 50 Ohm Spulenwiderstand und 3 geschalteten Relais bei 10% Unterspannung wird der minimale Spannungsabfall über dem Regler unterschritten.

Benutzeravatar
lab-freund
kann c't-Lab-Module umbauen
kann c't-Lab-Module umbauen
Beiträge: 88
Registriert: 23.01.2015, 20:27

Re: PS3-2 LM2940 im Leerlauf nicht stabil

Beitrag von lab-freund » 25.04.2015, 09:40

Schalten die Relais des DIV denn wenigstens bei Netzspannung am PS/2-Modul?
Kannst Du sagen, bei welchem Ausmaß an Unterspannung sie nicht mehr schalten?

Martin

Neuling
kann c't-Lab-Bausätze löten
kann c't-Lab-Bausätze löten
Beiträge: 29
Registriert: 15.06.2013, 12:45

Re: PS3-2 LM2940 im Leerlauf nicht stabil

Beitrag von Neuling » 09.05.2015, 11:53

Ich bin derzeit noch mit dem DCG beschäftigt und hatte nur eine Bestellung für das DIV vorbereitet. Daher beruhen meine Aussagen nur auf Berechnungen und Datenblättern.

Diese Berechnungen ergeben für drei 12V Finder Relais, dass bei Netz-Nennspannung für die Schaltung unter Berücksichtigung des Eigenverbrauchs der LDO-Regler nur ca. 15 mA übrig bleiben. Ich habe jetzt nicht die Zeit gehabt, aus der Schaltung mit Hilfe der Datenblätter nachzurechnen, ob dieser Strom ausreicht, zumal ich mich für die 6V Finder entschieden habe.

Antworten