DCG FUSEBLOWN, Relais schalten nicht

Hier könnt ihr Diskussionen über die Hardware und Abgleich des Labornetzteiles des c't-Lab führen.
pillex
kann c't-Lab-Bausätze bestellen
kann c't-Lab-Bausätze bestellen
Beiträge: 17
Registriert: 04.09.2008, 10:57
Wohnort: Berlin

Re: DCG FUSEBLOWN, Relais schalten nicht

Beitrag von pillex » 15.12.2009, 16:39

Hi Olnol,
hast Du mal mit dem Scope gemessen, ob an PB3 nicht wenigstens ein Pulse ganz am Anfang zu sehen ist?
Wenn nicht, miss doch mal direkt am ATMega pin 43.
Trenne doch mal das DCP vom DCG und lege an PL6/pin 8 5Volt an, z.B: vom PL1/pin 14. Das Relais 2 sollte arbeiten und dir an PL6/Pin 1 die 15V anbieten.

Ansonsten werden durch die Firmware die Relais nicht aktiviert im Fall von OverTemp oder OverVolt, wie Du vermutet hast.
Eine Möglichkeit wäre, dass der LM75 samt R2, R3, R4 nicht richtig gelötet oder defekt ist. OverVolt wäre z.B bei defektem Q12, was allerdings bei fehlender Spannung an PL6 unwahrscheinlicher ist. Eventuell kannst Du mal den I2C Bus mit einem DSO aufzeichnen, ob I2C_SDA(PL6 pin 6) 1->0 Übergänge zeigt (natürlich diesmal mit DCG zusammen).

Achtung! immer C16/C17 entladen bevor DCP und DCG verbunden oder getrennt werden.


Viel Glück
Pillex

olnol
träumt vom eigenen c't-Lab
träumt vom eigenen c't-Lab
Beiträge: 5
Registriert: 26.11.2009, 19:13

Re: DCG FUSEBLOWN, Relais schalten nicht

Beitrag von olnol » 15.12.2009, 17:12

Vielen Dank schonmal. Aber die Tatsache das der Lüfter nicht mehr ausgeht und ich 0,7 an OS vom LM75 anliegen habe deutet doch darauf hin, dass mit diesem etwas nicht stimmt. Die Temperartur ist def im grünen Bereich. Das er nicht richtig gelötet ist kann ich eig ausschließen, da das DCP/DCG zuvor funktionierte(bis auf Wicklungsumschaltung) und der FuseBlwn erst bei der Fehlersuche auftrat. Und ich kann mich auch erinnern das der Lüfter bevor ich nicht ständig Fuseblwn hatte, nur kurz anlief und dann wieder ausging.
Fuseblwn überschreibt mir ja immer die Eingabe im Hyperterminal, kann ich trotzdem irgendwie die vom LM75 gemessene Temp abgfragen, bzw ober OverTemp ausgelöst wurde?
Ich habe den Molexstecker def nicht gelöst, doch was hat das zur Folge wenn die C's noch nicht entladen sind?

pillex
kann c't-Lab-Bausätze bestellen
kann c't-Lab-Bausätze bestellen
Beiträge: 17
Registriert: 04.09.2008, 10:57
Wohnort: Berlin

Re: DCG FUSEBLOWN, Relais schalten nicht

Beitrag von pillex » 15.12.2009, 17:58

Da bei Trennen/Kontaktieren des Steckers nicht alle Kontakte gleichzeitig getrennt/kontaktiert werden, können unschöne Spannungspotenziale entstehen. In der Beschreibung des DCP wird gerade die Zerstörung des LM75 erwähnt :cry: .
Miss doch auch mal Q12/DCP nach.

Gruß Pillex

P.S: Bin mir nicht 100% sicher, aber trotzdem die FUSEBLOW Ausgabe kommt, müsstest Du trotzdem noch Kommandos an das DCP absetzen können - sozusagen blind tippen.

Antworten