Weglaufen des 2,5V und 250 mV Bereichs

Themen rund um die Hardware und Abgleich des Digitalvoltmeters DIV gehören hier rein.
Antworten
dg1vs
kann c't-Lab-Module konstruieren
kann c't-Lab-Module konstruieren
Beiträge: 132
Registriert: 20.12.2009, 22:26

Weglaufen des 2,5V und 250 mV Bereichs

Beitrag von dg1vs » 02.11.2013, 22:33

Hallo zusammen,

ich bin gerade dabei (nach langer Abstinenz) meine ct-Lab Baugruppen in ein Gehäuse zu packen. Ich habe aber beim DIV ein komisches Problem.

Ich habe die letzte Firmware von cm "wieder"-draufgespielt (ja ich weiß, aber als "Referenz") und das passende eep-File. Stromversorgung und serielles Schnittstelle über IFP. Nach Start findet der OFS-init Abgleich statt. Testmessungen mit 1.5V (2,5V und 25V) und 14,4V (25V und 250V) sahen erstmal gut aus, d.h. sinnvolle und plausible Ergebnisse.

Im 2.5V und 250mV Bereich läuft die Anzeige von positiven Werten auf den negativen Maximalwert mit [OVRNEG]. Kurzschluss liefert konstant fast 0V. Ist halt nicht abgeglichen.

Ich gebe zu, dass ich nicht sicher bin, ob das vor 2-3 Jahren auch schon so war, oder ob das ein neuer Effekt ist.

Ergänzung ich sehe gerade:
In viewtopic.php?f=7&t=554#p3995
ist da Thema schon mal diskutiert wurden. Da wurde aber von positiven Werten gesprochen.

Grüße Karsten

wAlter
kann c't-Lab-Module umbauen
kann c't-Lab-Module umbauen
Beiträge: 52
Registriert: 02.09.2013, 13:00

Re: Weglaufen des 2,5V und 250 mV Bereichs

Beitrag von wAlter » 03.11.2013, 11:05

Hallo zusammen,
ich bin mit dem DIV fast fertig und lese interessiert die Beiträge im Forum. Man muss ja nicht jeden Fehler selber machen.
Ich habe noch ein Verständnisproblem (schon noch mehere ...).
Warum ist es ausgerechnet im 2,5V Messbereich wichtig den 10MOhm Eingangswiderstand nicht zu haben? Wenn es einen wichtigen Grund gab oder gibt, würde ich ihn gerne wissen. Ansonsten gehört der Relaiskontakt SW6a entsprechend SW7a und SW1a angeordnet (naürlich unter Beibehalten der Schutzwiderstände R33 und R28). Dann hätten wir 10MOhm Eingangswiderstand in allen Spannungsmessbereichen. Das Wegdriften der Spannung wäre nicht mehr gegeben.
Danke im Voraus!
Grüße
Walter

psclab38
kann c't-Lab-Konstrukteure konstruieren
kann c't-Lab-Konstrukteure konstruieren
Beiträge: 897
Registriert: 25.01.2008, 23:34

Re: Weglaufen des 2,5V und 250 mV Bereichs

Beitrag von psclab38 » 03.11.2013, 12:35

Hallo Ihr beiden,
dg1vs hat geschrieben:Ich gebe zu, dass ich nicht sicher bin, ob das vor 2-3 Jahren auch schon so war, oder ob das ein neuer Effekt ist.
Ich vermute, das wird an dem Verhältnis der Leckströme von Q1 und Q2 liegen. Der Leckstrom von Q1 wird bei Deiner Baugruppe wohl dominieren.
wAlter hat geschrieben:Ich habe noch ein Verständnisproblem (schon noch mehere ...).
Warum ist es ausgerechnet im 2,5V Messbereich wichtig den 10MOhm Eingangswiderstand nicht zu haben? Wenn es einen wichtigen Grund gab oder gibt, würde ich ihn gerne wissen.
Ich nehme an, das war eine bewußte Designentscheidung von CM, um den hohen Eingangswiderstand des U6 "zu nutzen" und nicht mit den allgegenwärtigen 10MOhm zu überbügeln.

Viele Grüße
Paul

Benutzeravatar
ylf
kann c't-Lab-Module umbauen
kann c't-Lab-Module umbauen
Beiträge: 54
Registriert: 01.12.2007, 21:06
Wohnort: Waiblingen

Re: Weglaufen des 2,5V und 250 mV Bereichs

Beitrag von ylf » 12.11.2013, 16:59

Hallo zusammen,
wenn ich das richtig durchschaue auf die Schnelle, dann gibt es im 250mV Bereich auch keine 10MOhm. ;)
Ich habe jetzt nicht die Zeit, den Artikel nochmals durchzulesen. Die kleinen Messbereiche werden ja auch dazu missbraucht, die anderen Messungen, Strom und AC durchzuführen. Ggf. sind da 10MOhm hinderlich. Sollte eigentlich keine nennenswerte Rolle spielen. Und wie ich in dem anderen Thread schrieb, das DIV war aufwendiger geplant, soweit ich mich noch erinnern kann. Da sind zwangsläufig einige Kompromisse im Design.

Gruß, Jörg

Antworten